대한민국 대표 KOREAIDC!!

OpenSSH 제품 보안 업데이트 권고

□ 개요
 o OpenSSH에서 발생하는 취약점을 해결한 보안 업데이트 발표 [1]

 o 영향받는 버전을 사용 중인 시스템 사용자는 해결 방안에 따라 최신 버전으로 업데이트 권고

□ 설명
 o OpenSSH에서 발생하는 레이스 컨디션 취약점으로 인해 원격 코드 실행 가능 (CVE-2024-6387) [3][4]

□ 영향받는 제품 및 해결 방안

취약점

제품명

영향받는 버전

해결 버전

CVE-2024-6387

OpenSSH

4.4p1 까지*(제외)

9.8p1

8.5p1부터(포함) ~

9.8p1 까지(제외)

 * CVE-2006-5051, CVE-2008-4109 취약점 패치가 적용될 경우 양호하지만 최신 패치로 업데이트 권장 

영향을 받은 버전은 ubuntu 22.04 ~24.04 버전 및 RHEL 9  버전 영향을 받음

 ※ 하단의 참고사이트를 확인하여 업데이트 수행 [2]



□ 참고사이트
 [1]  https://www.openssh.com/security.html

 [2]  https://www.openssh.com/txt/release-9.8

 [3]  https://www.qualys.com/2024/07/01/cve-2024-6387/regresshion.txt

 [4]  https://nvd.nist.gov/vuln/detail/CVE-2024-6387